Skip to content

Instantly share code, notes, and snippets.

@rzezeski
Created January 21, 2021 02:49
Show Gist options
  • Save rzezeski/f4081cc46c452e18314cb4514b10bb65 to your computer and use it in GitHub Desktop.
Save rzezeski/f4081cc46c452e18314cb4514b10bb65 to your computer and use it in GitHub Desktop.
i40e update tests
These are my tests notes for the recent round of i40e updates, based on rm's branch:
https://github.com/rmustacc/illumos-gate/tree/i40e-dev
I believe related to this thread:
https://illumos.topicbox.com/groups/developer/Tccb1492df7a2b29c/test-request-and-code-review-i40e-updates
All tests run on DEBUG kernel.
prtconf: Ethernet Controller X710 for 10GbE SFP+
rpz@thunderhead:~/rpz-misc/illumos$ dladm show-phys
LINK MEDIA STATE SPEED DUPLEX DEVICE
igb0 Ethernet up 1000 full igb0
igb1 Ethernet up 1000 full igb1
ixgbe0 Ethernet up 10000 full ixgbe0
ixgbe1 Ethernet up 10000 full ixgbe1
i40e2 Ethernet up 10000 full i40e2
i40e3 Ethernet up 10000 full i40e3
rpz@thunderhead:~/rpz-misc/illumos/net-tests$ pfexec ./mac-tests i40e2 i40e3
PASS [test_mac_vnic_rx<i40e3>]
PASS [test_mac_vlan_rx<i40e3>]
PASS [test_mac_sw_to_hw<i40e3>]
PASS [test_mac_promisc<i40e3>]
PASS [test_mac_promisc_vlan<i40e3>]
PASS [test_mac_all_groups<i40e3>]
PASS [test_mac_vlan_all_groups<i40e3>]
PASS [test_mac_steal_group<i40e3>]
PASS [test_mac_vlan_steal_group<i40e3>]
PASS [test_mac_groups_vlan_shared_addr<i40e3>]
PASS [test_mac_vlan_shared_addr<i40e3>]
PASS [test_mac_two_vlans_on_default<i40e3>]
rpz@thunderhead:~/rpz-misc/illumos/net-tests$ pfexec ./lso-tests i40e2 i40e3
PASS [test_lso_ip4_primary<i40e2>]
PASS [test_lso_ip4_vnic<i40e2>]
PASS [test_lso_ip4_mac_loopback<i40e2>]
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
% The following tests will elide the LSO check until the %
% mac sw LSO is updated to handle IPv6 -- for now these %
& tests only verify that traffic is sent, not LSO. %
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
PASS [test_lso_ip6_primary<i40e2>]
PASS [test_lso_ip6_vnic<i40e2>]
PASS [test_lso_ip6_mac_loopback<i40e2>]
rpz@thunderhead:~/rpz-misc/illumos/net-tests$ iperf3 -c 192.168.66.3 -B 192.168.66.2 -t 10
Connecting to host 192.168.66.3, port 5201
[ 4] local 192.168.66.2 port 58795 connected to 192.168.66.3 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 225 MBytes 1.88 Gbits/sec
[ 4] 1.00-2.00 sec 251 MBytes 2.11 Gbits/sec
[ 4] 2.00-3.00 sec 96.0 MBytes 805 Mbits/sec
[ 4] 3.00-4.00 sec 249 MBytes 2.08 Gbits/sec
[ 4] 4.00-5.00 sec 210 MBytes 1.76 Gbits/sec
[ 4] 5.00-6.00 sec 214 MBytes 1.80 Gbits/sec
[ 4] 6.00-7.00 sec 222 MBytes 1.86 Gbits/sec
[ 4] 7.00-8.00 sec 220 MBytes 1.85 Gbits/sec
[ 4] 8.00-9.00 sec 220 MBytes 1.85 Gbits/sec
[ 4] 9.00-10.00 sec 223 MBytes 1.87 Gbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 2.08 GBytes 1.79 Gbits/sec sender
[ 4] 0.00-10.00 sec 2.08 GBytes 1.79 Gbits/sec receiver
@rzezeski
Copy link
Author

rpz@thunderhead:~$ pfexec mdb -k -e 'i40e_set_hw_flags/P'
i40e_set_hw_flags:
i40e_set_hw_flags:              0xec834857e5894855 

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment