Skip to content

Instantly share code, notes, and snippets.

@marrold
Last active August 24, 2024 16:40
Show Gist options
  • Save marrold/4c5ddba292bfcad128eb956141df64ca to your computer and use it in GitHub Desktop.
Save marrold/4c5ddba292bfcad128eb956141df64ca to your computer and use it in GitHub Desktop.
Cisco 3845 Dial-Up Network Access Server Configuration - T1 on IOS 15.3
! Configure the E1/T1 cards to use T1
!
card type t1 0 1
card type t1 1
!
!
! Set the default ISDN switch type
!
isdn switch-type primary-ni
!
!
! Configure the clock synchronisation for the T1s. We use the internal clock
! for the VWIC2-1MFT-T1/E1 and the 1CE1T1-PRI uses the clock on the line
! provided by the 1MFT-T1/E1
!
network-clock-participate slot 1
network-clock-participate wic 1
network-clock-select 1 E1 1/0
!
!
! Configure the T1 controllers. The controller on 0/0/0 gets it's clock
! internally. Also configure the timeslots - we use all of them, but
! if you don't have enough PVDMs you might want to use a fractional circuit.
! make sure it matches on both ends.
!
controller T1 0/1/0
no shutdown
cablelength short 110ft
clock source internal
pri-group timeslots 1-4,16
!
controller T1 1/0
no shutdown
cablelength short 110ft
pri-group timeslots 1-4,16
!
!
! Configure the Serial Interfaces (The "D" channels on the PRI circuit).
! Serial0/1/0:23 is the 1MFT-T1/E1 acting as the "network" and Serial1/0:23
! is the 1CE1T1-PRI acting as a "user". "isdn incoming-voice modem" forces
! incoming calls to the modem bank.
!
interface Serial0/1/0:23
no shutdown
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial1/0:23
no shutdown
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice modem
no cdp enable
!
!
! Add an IP to the a Loopback interface for dial up clients to use as the gateway
!
interface Loopback0
ip address 10.1.8.1 255.255.255.0
!
!
! Configure the subnet-mask, gateway and DNS server for dial up clients
!
async-bootp subnet-mask 255.255.255.0
async-bootp gateway 10.1.8.1
async-bootp dns-server 8.8.8.8
!
!
! Configure the pool of IPs for the Dial Up Clients
!
ip local pool async 10.1.8.2 10.1.8.255
!
!
! Define a list of "interesting" traffic that keeps the dial up connection open.
! We select all IP traffic
!
dialer-list 1 protocol ip permit
!
!
! Configure an access list to use for NATing traffic
!
access-list 1 permit 10.1.8.0 0.0.0.255
!
!
! Configure NAT to use access-list 1 and interface Gi0/0
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
!
!
! Configure the interface as outside for NAT
!
interface GigabitEthernet0/0
ip nat outside
!
! Configure the async interfaces. We use a group to apply the settings to all
! of the async interfaces at once. A description of each parameter is below:
!
! no shutdown = Make sure the device isn't shut down
! ip unnumbered Loopback3 = Use the Loopback3 interface
! ip nat inside = This interface is inside NAT.
! encapsulation ppp = Use ppp encapasulation
! dialer in-band = Use in-band management
! dialer idle-timeout 600 = Set the idle timeout to 600 seconds
! dialer-group 1 = Assign to dialer group 1
! peer default ip address pool async = Set the IP address pool.
! async mode dedicated = Dedicated only, disable console access
! no keepalive = Disable keep alive
! ppp authentication chap = Use CHAP authentication
! ppp multilink = Enable MLPPP
! group-range 2/0 2/5 = Apply these settings to all the modems.
!
interface Group-Async0
no shutdown
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool async
async mode dedicated
no keepalive
ppp authentication chap
ppp multilink
group-range 2/0 2/5
!
!
! Configure modems for United Kingdom. You might want to update this to your
! location, but I've not tested others.
!
modem country mica united-kingdom
!
!
! Configure the modemcap to sane defaults
!
modemcap entry v92:MSC=&F&D2S54=16584S0=0S29=12S21=15S62=8S63=3S34=18000S40=10S10=50
!
!
! Configure the modem lines. A description of each parameter is below:
!
! modem InOut = Allow modem in and out
! modem autoconfigure type default = Use modemcap "default"
!
line 2/0 2/5
modem InOut
modem autoconfigure type v92
!
!
! Configure the voice ports (FXSs). In theory you can set the station-id number
! to whatever you like. You should also customise the ring and cptone to your
! location. A description of each parameter is below:
!
! ring cadence pattern11 = Sets the ring cadence to patern11 (UK ring-ring)
! compand-type a-law = Forces the port to a-law.
! cptone GB = Sets the call progress tones to Great Britain
! station-id number 1001 = Set the station-id (extension) number
!
voice-port 0/1/0
no shutdown
compand-type u-law
station-id number 1001
!
voice-port 0/1/1
no shutdown
cptone US
compand-type u-law
station-id number 1002
!
voice-port 0/1/2
no shutdown
cptone US
compand-type u-law
station-id number 1003
!
voice-port 0/1/3
no shutdown
cptone US
compand-type u-law
station-id number 1004
!
!
! Configure the dial-peer to route calls over the T1 to the modems.
! A description of each parameter is below:
!
! destination-pattern 1000 = Sets the number to call the modem bank (1000)
! port 0/1/0:23 = Routes the call over the T1
! forward-digits all = Forwards all digits over the T1
!
dial-peer voice 1000 pots
destination-pattern 1000
port 0/1/0:23
forward-digits all
!
!
! Create a user for use with the PPP connection
!
username dialuser privilege 0 password 0 password
!
!
! Move the exec / enable command to privilege level 1 to limit what the dialuser has access to
!
privilege exec level 1 enable
@Dr-Wily
Copy link

Dr-Wily commented Jan 18, 2024

Is the FXS card can generate phone tone ? Some devices refuse to dial if there no phone tone. Plus, the NM-6DM card is difficult to find. I you have tips to find it a reasonable price, I take. ;)

@rkrenicki
Copy link

rkrenicki commented Jul 31, 2024

Is the FXS card can generate phone tone ? Some devices refuse to dial if there no phone tone. Plus, the NM-6DM card is difficult to find. I you have tips to find it a reasonable price, I take. ;)

@Dr-Wily The VICx-4FXS/DID cards are indeed the version that generate a dial tone. I do agree that NM-xxDM modules are quite difficult to find nowadays. I fear that you and I are a few years too late to the game here.

@marrold I noticed that you indicated that this is for IOS version 15.3, but I do not believe that version was ever available on the 3800 series. Did you perhaps mean 15.1(3)?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment