Skip to content

Instantly share code, notes, and snippets.

@hanvari
Created June 1, 2018 09:10
Show Gist options
  • Save hanvari/ad011784682bcb594e543b4b7293136b to your computer and use it in GitHub Desktop.
Save hanvari/ad011784682bcb594e543b4b7293136b to your computer and use it in GitHub Desktop.
Create Bootable USB from ISO file in MacOS

Create Bootable USB stick form ISO in MacOS

Convert ISO to UDRW format

$ hdiutil convert -format UDRW -o destination_file.img source_file.iso

Prepare USB stick

  1. Find usb stick device file
$ diskutil list

Let's say it is /dev/disk2

  1. Partitioning the usb stick:

Warning: This will erase all data

$ diskutil partitionDisk /dev/disk2 1 "Free Space" "unused" "100%"

Copy the image to the USB stick

$ sudo dd if=destination_file.img.dmg of=/dev/disk2 bs=1m
  • This will be long running with no output. Pressing CTRL+T will show the current status of the command.

Eject USB stick

$ diskutil eject /dev/disk2

Done!

Reference: https://blog.tinned-software.net/create-bootable-usb-stick-from-iso-in-mac-os-x/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment